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Automation is a way to generate and distribute multiple reports across your NetSuite segments (e.g.
Subsidiaries, Classes, Departments, Locations, etc.) from a single template, without manually copying
or creating individual reports for each. These generated reports are built using Solution 7's Automation
feature and can be distributed in a format that is available to non-Solution 7 users.

In Solution 7 Training Guide - Basic Concepts & Building Your First Report, we learned how to create an

interactive, dynamic and refreshable report template from your live, real-time NetSuite data. In this

lesson, we will use that same P&L (Income) Statement template and Solution 7's Automation feature
to generate and distribute your automated reports.

You may also follow the exercises in this guide to use Automation on your own pre-existing reports.
Before we begin, there are some items that we will refer to during the lesson.

The information in this training guide is positioned from a NetSuite OneWorld user of Solution 7. If you
are not running NetSuite OneWorld, you will be able to follow the exercises, but some dialogs may
appear slightly differently to the screenshots (i.e. missing Subsidiary). In that case, where this
document refers to Subsidiary, please substitute as appropriate to your instance of NetSuite.

When you first start Excel, Solution 7 is not automatically activated. You may be opening and/or editing
Excel workbooks that have no NetSuite content. Solution 7 only needs to be activated if you are
building new NetSuite report templates or need to refresh data in existing templates. Once activated,
one of your Solution 7 licenses will be considered “in use”. To release the license for another user,
simply close Excel.

To activate Solution 7 within Excel, click Solution 7 > Activate.

File Home Insert Page Layout Formulas Data Review View Developer Help Solution 7

S| e ?

Activate | Configure About

Actions System

Solution 7 will now attempt to establish a connection to NetSuite and, if successful, will expand the full
Solution 7 ribbon.

If you don’t see the Solution 7 menu or Solution 7 fails to activate, please refer to the
or contact support@solutionz.co.uk.
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The Solution 7 Ribbon expands after activation and is the starting point when using any of Solution 7's

features.
File Home Insert Page Layout Formulas Data Review View Developer Help Solution 7 LOAD TEST Power Pivot Team Location Analysis
5 @ @ HII =] % T2 Print Sheet(s) |:1 i) [:9] suppress EI Eq fa - oo

[% E ﬁ( @ [ Save Sheet(s) o Unsuppress S (=] b= 1 ’?

Refresh  Listand Table | Column Row Pop-up Function | Summary Detail Define Define Lock/Drop  Delete Developer Budgets & | Configure About
- Manager - ~ - ~ ~ ~ Automation (5 Email Sheet(s) Suppression Formulas ~ Drill Down Tools ~ Forecasts ~
Data Lists & Functions PivotTables Automation Zero Suppression Actions System
Al et I
A B € D E F G H | J K L M N ] Q R S
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Automation Basic Concepts

At the most basic level, automation is a way of automatically pushing cell values into a workbook. We
can do this through what we call an automation ‘control’ sheet.

Exercise 1 — Creating an automation control sheet

In this exercise, we will learn the basic concepts of Automation by building an automation ‘control’
sheet from a blank Excel workbook. In practice, you would typically use Automation to generate
multiple finished reports from an existing Solution 7 report template.

Begin on a blank Excel workbook and with Solution 7 activated, follow these steps:-

Step 1:

Solution 7 requires you to save the workbook before you automate to ensure no loss of data.
Go to File > Save As and save this new workbook.

Step 2:

Click Define Automation. This will give access to the Automation dialog where you can select the cell
you would like to automate.

File Home Insert Page Layout Formulas Data Revi Help Solution 7

I:B,S E @ E:El ﬁ @ E: 01 Print Sheet(s) I:(l)(l) [i] suppress EI @ E[%] @

fE]Save Sheet(s) Unsuppress
Refresh | Listand Table | Column Row Pop-up Function | Summary Detail Define Define Lock/Drop  Delete Developer Budgets &
= Manager = = = = = = Automation [ Email Sheet(s) Suppression Formulas ~ Drill Down Tools~  Forecasts ~
Data Lists & Functions PivotTables Aufomation Zero Suppression Actions

On the Automation dialog, click Add.

Automation *

Cells

Select the cells to automate.

Cell Range

REmave Remave Al

Values

Walues will be specified on an automation sheet.

An automation sheet will be created after
selecting at least one cell to automate and
clicking ‘OK.

OK | Cancel
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Step 4:

Select empty cell C3 and click OK.

Step 5:
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Financial Reporting

A B C D E F G
1
2
: ]
4 {
5 | Select a Range
3 | |scs3
T
8
9
10

On the Automation dialog, click OK to create your first automation ‘control’ sheet. This will be
generated on a new sheet called ‘Automation’.

Cells

Select the cells to automate.

Cell Range

"Sheet1'18C53

Remaove All

Edit Remove

Values

Values will be specified on an automation sheet.

An automation sheet will be created after
selecting at least one cell to automate and

clicking 'OK.
| OK | Cancel

D17 h S

A B © D E F G
1 |Automation Sheet
2
3 |This sheet is used to automate workbooks and worksheets as defined in the 'Define Automation' dialogue.
4 |Please complete each column below with the following information:
5
6 |Cell1l.n The combination of automation values
7 |Workbook NanThe name given to the resulting workbook(s) (not required for printing).
8 |Email Address The recipient(s) email address(es), separated by semi colons (not required for printing or saving).
9
10 |Where a Workbook Name or Email Address is left blank, it's value will be taken from the previous row.

L
112 |Cell 1 Workbook Name Email Address
13 |Sample Data 1 [Enter Workbook Name Here] [Enter Email Address Here]

You can configure this ‘control’ sheet to define your required output by providing values for
each of the automation cells, indicating how they will be grouped into separate workbooks
and specifying an email recipient list.

Page7of3s
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Step 6:
To learn about the Automation process, we will first enter some very simple data.

In cells A13 — A16 enter the values “London”, “Paris”, "New York”, “Munich”.

Bl = I
A B 18 D E F G

Automation Sheet

| This sheet is used to automate workbooks and worksheets as defined in the 'Define Automation' dialogue.
|Please complete each column below with the following information:

|CellL.n The combination of automation values
Workbook NanThe name given to the resulting workbook(s) (not required for printing).
'|Email Address The recipient(s) email address{es], separated by semi colons (not required for printing or saving).

[T=N--ICN I - (TR I S TR R S I

10 Where a Workbook Mame or Email Address is left blank, it's value will be taken from the previous row.

12 |Cell1 \Lrorkbook Name Email Address

13 | London [Enter wWorkbook Name Here] [Enter Email Address Here]
14 |Paris

15 |New York

16 [Munich

Step 7:

In cell B13 under Workbook Name, provide a name for the generated workbook by entering:
‘Automation exercise 1.

Step 8:
On the Solution 7 ribbon, click Save Sheet(s).
File Home Insert Page Layout Formulas Data Review View Help Solution 7
B =] B E Print Shastls) 10 E',',j Suppress
[3 B B Hy A EE =l 1 b
e |_—['§] Save Sheet(s) Unsuppress
Refresh  List and Table | Column Row Pop-up  Function | Summary Detail Define ) Define Lock/Drop
= Manager = = = = = = Automation BrdErmitStreetts) Suppression Farmulas ~
Data Lists & Functions PivotTables Automation Zero Suppression
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Step o:

From the Save as Files(s) dialog, we can select which sheets to automate and specify how the reports
are created.

With ‘Sheet 1 highlighted, select Copy Sheet Per Automation Row.

Click OK to run automation and create your reports.

Save as File(s) X

Shest Selection  Options
Sheets to Save

[ Shest

Cldond Nogs

|‘ (® Copy Sheet Per Automation Row (O Copy Sheet Per \Workbook

© Name Sheet  |Shest!

& IMPORTANT: Your waorkbook will be saved before running automation.

| hedty  [[ 0K ][ cancel |

e 'Sheet1’isthe worksheet we are automating. Because our workbook only contains one
worksheet, ‘Sheet 1'is the only option. If we had multiple worksheets, each one would appear
in the list.

e Copy Sheet Per Automation Row creates a new report sheet per cell entered in column A.

e Copy Sheet Per Workbook creates a new report sheet per workbook entered in column B.

For each cell value in column A, (Cell 1) of our automation ‘control’ sheet a new sheet will be
created in the workbook named in column B (Workbook Name).

Step 10:

Once automation is complete, you will receive the completion message below.
Go to File > Open and open your automated report. It will be saved as ‘Automation exercise 1.xIsx’.

Automation x

o Automation complete, 1 workbook(s) saved,
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For each city name we entered in the automation ‘control’ sheet, a new sheet has been created. Within
that sheet, cell C3 (the automation cell) has been populated with the city.

c3 = fe ‘London
A B (€ D E F G

1

2

a

4

5

6

1

8

9

10

1

12

| | sheett | sheeti@) | sheetiz) | sheeti ) || @

Exercise 2 — Automating multiple cells

In this exercise, we will take the basic concepts from Exercise 1 and learn how we can use Automation
to push values into multiple cells across multiple worksheets.

Begin on a blank Excel workbook and with Solution 7 activated, follow these steps:-

Step 1:

Solution 7 requires you to save the workbook before you automate to ensure no loss of data.
Go to File > Save As and save this new workbook.

Step 2:

Click Define Automation.

File Home Insert Page Layout Formulas Data Revi

2 & EBEB A | =8 e | O M= | O B @ @

Save Sheet(s)

Help Solution 7

Refresh  Listand Table | Column Row Pop-up  Function | Summary Detail Define Define Lock/Drop  Delete Developer Budgets &
~ Manager ~ - ~ - A = Automation |58 Email Shest(s) Suppression Formulas ~ Drill Down Tools~  Forecasts ~
Data Lists & Functions PivotTables yfomation Zero Suppression Actions

Step 3:
On the Automation dialog, click Add.
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Automation x

Cells

Select the cells to automate:

Cell Range

[ 8d || Edt || Remove | |Removesu

Values

Walues will be specified on an automation sheet.

An automation sheet will be created after
selecting at least one cell to automate and
clicking 'OK.

Step 4:

Select empty cell C3 and click OK.

Step 5:

On the Automation dialog, click Add a second time.
Step 6:

Select empty cell C5 and click OK.

Step 7:

On the Automation dialog, click OK.

Automation X

Cells
Select the cells to automate.

Cell Range
1 ‘Sheet1315CS3

‘Sheet13'1$C35

Add_ | Edit | | Remove | RemoveAl

Values

Values will be specified on an automation sheet.

An automation sheet will be created after
selecting at least one cell to automate and
clicking 'OK.

Step 8:

In column A (Cell 1) and column B (Cell 2), enter the values as they appear below. As in the previous
exercise, Cell 1 represents the first cell we selected to automate (C3) and this time Cell 2 represents the
second cell we selected (Cg).
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Al3 ~ £ || New York
A B T D E F G
1 Automation Sheet
2 |
3 |This sheet is used to automate workbooks and worksheets as defined in the 'Define Automation’ dialogue.
4 |Please complete each column below with the following information:
5 =
6 |Celll.n The combination of automation values
7 |Workbook NanThe name given to the resulting workbook(s) (not required for printing).
& |Email Address The recipient(s) email address(es), separated by semi colons (not required for printing or saving).
9 =
10_Where a Workbook Name or Email Address is left blank, it's value will be taken from the previous row.
12-{:ell 1 Cell 2 Workbook Name Email Address
13 |New York Shop Sales [Enter Workbook Name Here] [Enter Email Address Here]
14 |New York Online Sales
15 |Boston Shop Sales
16 |Boston Online Sales

Step o:

Under Workbook Name enter ‘Automation exercise 2’ and click Save Sheet(s).

= o] =] Ca Print Sheet ]0:|
2. 200 LEBE E e
Refresh | Listand Table | Column Row Pop-up  Function | Summary Detail Define Define
~ Manager ~ ~ ~ ~ ~ ~ Automation | A% EMall SREES, Suppression
Data Lists & Functions PivotTables Automation Zero 5
Al3 - fe || MewYork
A B C D E F G
1 Automation Sheet
2
3 |This sheet is used to automate workbooks and worksheets as defined in the 'Define Automation' dialogue.
4 |Please complete each column below with the following information:
5
6 |Cell 1..n The combination of automation values
7 |Workbook NanThe name given to the resulting workbook(s) (not required for printing).
& Email Address The recipient(s) email address(es), separated by semi colons (not required for printing or saving).
9
10 'Where a Workbook Name or Email Address is left blank, it's value will be taken from the previous row.
11
12 [Cell1 Cell2 Workbook Name Email Address
13 |New York Shop sales Automation exercise 2 Enter Email Address Here]
14 [New York Online Sales
15 |Boston Shop Sales
16 |Boston Online Sales
17

Step 10:

With ‘Sheet 1 highlighted, select Copy Sheet Per Automation Row.

Click OK to run Automation and create your reports in a new workbook.
Step 11:

Go to File > Open and open your automated report. It will be saved as ‘Automation exercise 2.xlsx’.
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c3 - 5 'New York

A B c D E | F
1_
2_ - T T |
3 | New York
4 | - -
5 | Shop Sales
6_
?_
8_
g_
10
1]
12|

Sheetl Sheet1 (2) Sheet1 (3) Sheet1 (4)

c5 ~ fe ‘Online Sales
A B C D E | °F

1_

2_

3 | Mew York

4_ _I T |

5| | Online Sales |

6_

7—

8—

9_

10

1

12

| Sheet1 | Sheetl (2) | Sheetl (3) | Sheet1 (4) |

Like in the previous exercise, the values have been pushed into our chosen cells.

‘ Cc3 - Fe '‘Boston
A B C D E F |

1_

2_ |

3 | | Boston

4 | - -

5 | Shop Sales

6_

?_

8_

9_

10

1]

12

Sheet1 Sheet1 (2) Sheet1 (3) Sheetl (4)
e —
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C5

=R RN T R ST R R

P [
R =

e 'Online Sales
B C D E F
Boston
Online Sales
Sheet1 Sheet1 (2) Sheet1 (3} Sheet1 (4)

It can take up to several minutes for Solution 7 to create your reports depending on the
number of cells you want to Automate, NetSuite servers and your internet connection.

Page 14 0f 35
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So far we have learned how to use Solution 7's Automation feature to create an automation ‘control’
sheet and push values into selected cells. In the next exercises, we will learn how to apply these
concepts to an existing report template built using Solution 7 and see how reports can easily be
generated and distributed across your important reporting segments.

Exercise 3 — Define automation

In this exercise, we will learn how to automate the distribution of an existing P&L (Income) Statement
template.

Begin with P&L (Income) Statement made in ‘Solution 7 Training Guide - Basic Concepts and Building
Your First Report’ and with Solution 7 activated, follow these steps:-

Step 1:
Go to File > Save and save a separate copy of the report.
539 e F3
Name Box
= C D E F G H J K L M N [s] P
2
3 HH Inc. (Consolidated)
4 2019 Jan 2019 Feb 2019 Mar 2018 Apr 2019 May 2019 Jun 2018 Jul 2019 Aug 2019 Sep 2018 Oct 2019 Nov 2018 Dec 2019 Total 2019
5
3 4000 Sales 1,804,603 2,556,583 10,457,763 8,261,614 7,671,381 720,227 992,159 975,900 3,135,483 2,077,940 1,717,744 4,273,136 | 44,646,534
7 2002 sales - Merchandise 1,536,887 2,074,103 240,318 13,445 33,729 29,957 10,989 15,189 51,583 38,154 26,842 64,227 | 4,335,423
8 2004 sales - Service 288,449 442,315 331,467 282,027 362,749 275,732 246,332 260,623 825,270 794,143 673,295 1,195,588 | 5,977,989
9 4006 sales - Clearance 26,340 23,400 - 9,357 - - 15,447 15,600 - - - - 90,144
10 4008 Sales - Warranty 3,164,828 2,273,344 2,348,541 2,010,987 1,931,823 158,758 222,810 142,567 556,432 396,582 433,559 809,958 | 14,450,249
1 4100 WIP eRev (7.360) - - - - - - - - - - (7,360)
12
13 Total Sales 6,821,106 7,362,384 13,578,089 10,577,431 9,999,682 1,184,675 1,487,738 1,409,879 4,568,828 3,306,818 2,851,440 6,344,908 | 69,492,980
14
15
G 2019 - Sales 2019 - Trend
17 u Sales .16
18 - s 1
Sales - Merchandise s 12
12 =
20 Sales - Service 10
21 8
22 — Sales- Clearance 6
23 B 4
1 Sales- Warranty 2
= = WIP eRev Jan  Feb Mar Apr May Jun Ju  Aug Sep Oct Nov Dec
26 2019 2018 2019 2019 2019 2019 2019 2019 2019 2019 2019 2019
27
28
Step 2:
Go to Define Automation and remove any previously automated cells.
Click Add.

Select cell C3 (the Subsidiary cell) as your automation cell and click OK.

Page 15 of 35

A B © D E F G
2 =
3 | L;JH Ine. {Consolidated) %lJ
4 ik an 2019 Feb 2019 Mar 2019 Apr 2019
5 | — T ; =
6 | 2000  sales I ' B,261,614
7| 4002 Sales - Merchandise Select a Range 13,445
8 | 4004 Sales - Service | |5€53 | 282,027
g 4006 Sales - Clearance 9,357
10 4008 sales - Warranty el | 5 010,987
11| 4100 WIP eRev _— (7,360 - -
12
13 Total Sales 5,821,106 7,362,384 13,578,089 10,577,431
14
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Step 4:
On the Automation dialog, click OK.

Automation >

Cells

Select the cells to automate.

"Sheet1'13C33

. Add | Edit | Remove | Remove Al

Walues

Walues will be specified on an automation sheet.

An automation sheet will be created after
selecting at least one cell to automate and
clicking 0K

oK || cancel

Step 5:

When you click OK, Solution 7 will recognise that the automation cell is a pop-up list and display the
below message asking if you would like to populate the automation sheet with values from this list.

Click Yes.

Solution 7 4

Some of the selected cells contain pop-up lists, Would you
like to populate the automation sheet with values from these
cells?

Yes | | Mo | | Cancel

The pop-up list contains all the Subsidiaries we wish to automate. By including the values in
the pop-up, we are going to create a new P&L (Income) Statement for each of your NetSuite
Subsidiaries.
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The automation ‘control’ sheet will be created, allowing us to configure the output we require. This
time, column A (Cell1) has been pre-populated with the values from the pop-up list.

B13 - x v K
A B 8
1 Automation Sheet
2
3 |This sheet is used to automate workbooks and worksheets as defined in the 'Define Auton
4 |Please complete each column below with the following information:
5
6 |Cell 1..n The combination of automation values
7 |wWorkbook Name The name given to the resulting workbook(s) (not required §
8 |Email Address The recipient(s) email address(es), separated by semi colon
9

10 |Where a Workbook Name or Email Address is left blank, it's value will be taken from the p

2 |Celll Workbook Name Email Address
3 |HH Inc. (Consolidated) [Enter Email Address Here]
4 |HH Inc.

5 |HH Inc. : Honeycomb Mexica
6 |HH Inc. : Honeycomb USA

18
19
20
21

22

If you do not wish to automate on a value in column A, simply hide or delete the row.

In cell B13 under Workbook Name, enter ‘Automation exercise 3'.

On the Solution 7 ribbon, click Save Sheet(s).

With ‘Sheet 1" highlighted, select Copy Sheet Per Automation Row.

Click OK to run Automation and create your reports.

Go to File > Open to open your newly created report. It will be saved as ‘Automation exercise 3.xlsx’ in
the same folder as your report template. Notice how like in Exercise 1, Solution 7 has created a new
worksheet per cell value in column A.

You have now created your first report template for a P&L (Income) Statement. Follow these
steps to automate reports for your other NetSuite segments. (l.e. Class, Department,

Location).

Page 17 of 35
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After choosing one of the Automation Distribution options (Print Sheet(s), Save Sheet(s) or Email
Sheet(s)), the Automation options allow you to further refine the output of your report.

Page 18 of 35

Save as File(s) >

Sheet Selectio]  Options
Sheetsto SavE

[ Sheet

™ Sheetl

R

(®) Copy Sheet Per Automation Row () Copy Sheet Per \Workbook

Name Sheet |

A IMPORTANT: Your workbook will be saved before running automation.

ety [ OK ]| Cancal

Save as File(s) b
Sheet Selection Options

Workbook
[ Apply Zero Suppression

Formulas

() Leave Formulas (8 Drop Formulas ) Lock Formula Values

Protection

[] Protect shests and contents of locked cells

Password (optional):

Cther
[] Create Folder Structure [] Ignore Hidden Rows

b IMPORTANT: Your workbook will be saved before running automation.

mesly [ oK ][ cancel |

Zero Suppression — Applies suppression defined in the sheet to hide all zero value rows.

Leave Formulas — Retains the formulas in the worksheet.

Drop Formulas — Removes the formulas to leave static values.

Lock Formula Values — Similar to Drop Formulas but is reversible. I.e. Formulas can be

“unlocked” later.

Copyright © 2022 Solution 7 Ltd — All Rights Reserved
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e Protect sheets — Protects the worksheets with a password.

e Create Folder Structure — If checked, this will create the folders specified when using a file path.
If unchecked and the folder does not exist, an error will be reported.

e Ignore Hidden Rows — Hidden rows on the automation sheet will be ignored.
e Apply —Save the settings without running automation.

e OK-Save the settings and run automation.

Dropping or Locking Formulas provides a way of distributing reports in a static format that can be
viewed by users who do not have Solution 7 installed.

Continue with the automation ‘control’ sheet from the previous exercise and with Solution 7 activated,
follow these steps:-

In column B, under Workbook Name, enter ‘Automation exercise 4'.
With the cursor in an empty cell, click Save Sheet(s).
With ‘Sheet 1’ highlighted, select Copy Sheet Per Automation Row and click the Options tab.

Select Drop Formulas.

Click OK to run automation and create your report.

Save as File(s) =

Sheet Selection Options
Workbook
[ Lpply Zero Suppression

Formulas

(O Leave Formulas| (@ Drop Formulas (O Lock Formula Values

Protection
[] Protect sheets and contents of locked cells

Password (optional):

Cther
[] Create Folder Structure Ignore Hidden Rows

/2 IMPORTANT: Your workbook will be saved before running automation.

sorly Cones

Go to File > Open to open your report. It will have been saved as ‘Automation exercise 4.xIsx’
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Click on cell D6 and look to the formula bar. Notice how the Solution 7 formula has been dropped to

leave a static value.

Do h 5 1804603.42
A B C D E F

2

3 HH Inc. (Consolidated)
4 2019 Jan 2019 Feb 2019 Mar 2019
5

6 4000 Sales | 1,804,603 .l 2,556,583 10,457,763
7 51002 Sales - Merchandise 1,536,887 2,074,103 440,318
8 :1004 Sales - Service 288,449 442,315 331,467
9 T1006 Sales - Clearance 26,340 23,400 -
10 :?-DDS Sales - Warranty 3,164,828 2,273,344 2,348,541
11 "2100 WIP eRev - {7,360) -
12
13 Total Sales 6,821,106 7,362,334 13,578,089

D& - g =-NSGLABAL($CS3,586,054)

B C D E F

2

3 HH Inc. (Consolidated)

4 2019 Jan 2019 Feh 2019 Mar 2019
5

6 4000 Sales | 1,804,603 .l 2,556,583 10,457,763
7 4002 Sales - Merchandise 1,536,887 2,074,103 440,318
8 4004 Sales - Service 288,449 442,315 331,467
g 4006 Sales - Clearance 26,340 23,400 -
10 4008 Sales - Warranty 3,164,828 2,273,344 2,348,541
11 4100 WIP eRev - (7,360) -
12

13 Total Sales 6,821,106 7,362,384 13,578,089

As you can see, the Solution 7 functionality has been removed to leave static values. Repeat
the steps in this exercise for all the Automation options to see what each achieves.
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Now we have learned how to generate multiple reports through Automation, in this section we will use
Excel’s native functionality and learn how to create a summary report for multi-sheet reporting. A
report’s summary sheet displays the combined values of your multi-sheet workbook.

Exercise 5 — Creating a summary sheet

In this exercise, we will create a summary sheet using native Excel functionality.

Continue with the P&L (Income) Statement and automation ‘control’ sheet from the previous exercise
and with Solution 7 activated, follow these steps:-

Step 1:
Add a new worksheet to your existing workbook and rename from ‘Sheet2’ to ‘Summary’.
Step 2:
On the Summary sheet, click into empty cell D6.
Step 3:
Go to the Home ribbon and select Excel’s AutoSum feature.
Data Review View Help Solution 7
= e EE}Wrap Text General ~ @ @ @ Binsert ~ | E ) %? p
Conditional Fi t Cell EDEI&E e Sort & Find &
— = 5= - - O &0 .00 onditiona armat as €l — 0 n
= == [ Merge & Center $ % 9 9t Formatting ~ Table~ Styles ~ {2 Format ~ € Filter ~ Select ~
Alignment ] Mumber ] Styles Cells Editing
Step 4:

Go to the report in ‘Sheet1’ and select the first consolidated value in cell D6. This will insert the =SUM
function, sheet number and cell reference into the formula bar.

X v K =SUM(Sheet1!D6)

C

D

D6 <
A B

2_

3_

4_

5_

6 | 4000

7 | 4002

g | 4004

9 | 4006

10| 4008

1 4100

HH Inc. [Consolidated)
2019

Sales

Sales - Merchandise
Sales - Service
Sales - Clearance
Sales - Warranty
WIP eRev

Total Sales

Jan 2019 Feb 2019 Mar 2019
“1304,60a1 2556582 10,457,763
1,536,887 2,074,108 440,318
288,449 442315 331,467
26,340 23,400 -
3,164,828 2,273,344 2,343,541
- (7,360) -

6,921,106

7,362,384 13,578,089

2019 -

y

Automaticnl | Sheetl ||‘Summar;|r
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Press Enter on your keyboard to complete the function. You will see that the same formula has been
entered into our summary sheet formula bar. This tells Solution 7 to summarise the values from cell D6
in the report template (Sheeta) into cell D6 of our summary report sheet.

Step 6:

‘Dﬂ N Ff | =sUM(Sheet1!D6)
A B C D E F G

1-

2-

3_

4_

5_

& | 1304603

?_

8_

g_

10|

11|

12 |

Automation Sheetl | Summary .:-B.

Copy the formula across to column O and then all the way down to row 11.

Change between ‘Sheet1’ and ‘Summary’ to see how the values have been inserted into the worksheet.

P13 = p
A B D E F G H | J K L M N o] P

1

2

3

4

5

6 1804603.4 2556582.86 10457763 8261614.5 7671381 720227.1 992159.5 975899.57 3135483.4 2077939.9 1717744.1 4275135.81
7 1536886.9 2074102.52 440317.63 13445.08 33728.72 29957.37 10988.82 15189.47 51583.45 38154.02 26841.87  64226.78
8 288448.69 442314.92 331467.33 282026.73 362748.8 2757325 246332 260622.87 825269.9 794142.51 673295.46 1195587.5
9 26339.73 23400 0 9357.2 0 0 15447.35 15600 0 0 0 0
10 3164827.7 2273344.16 23485414 2010987.3 1931823 158757.8 222809.9 142567.06 556491.74 39658L.65 433559.04 B09958.26
1 0 -7360 0 0 0 0 0 0 0 0 0 0
12

13

14
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Step 7:

You can now copy the Year, Account Titles, Period Titles, Totals and apply appropriate formatting and
charts (optional) to make the Summary sheet resemble the image below.

R3 - A

A A | B | C | D | E | F | G | H | | | J | K | L | M | N | o | P | Q
1] 01/01/2019 01/02/2019 01/03/2019 01/04/2019 01/05/2019 01/06/2019 01/07/2019 01/08/2019 01/09/2019 01/10/2019 01/11/2019 01/12/2019

2|

3

4 | 2019 Jan 2019 Feb 2019 Mar 2019 Apr2019  May 2019  Jun 2019 Jul 2019 Aug2019 Sep2019 Oct2019 Nov2019 Dec2019 | Total 2019
5|

6 4000 Sales 1,804,603 2,556,583 10,457,763 8,261,614 7,671,381 720,227 992,159 975900 3,135483 2,077,940 1,717,744 4,275,136 | 44,646,534
7 4002 Sales - Merchandise 1,536,887 2,074,103 440,318 13,445 33,729 29,957 10,989 15,189 51,583 38,154 26,842 64,227 | 4,335,423
8 4004 sales - Service 288,449 442,315 331,467 282,027 362,743 275732 246,332 260,623 825,270 794,143 673,295 1,195,588 | 5,977,989
o 4006 sales - Clearance 26,340 23,400 - 9,357 - - 15,447 15,600 - - - - 90,144
10/ 4008 Sales - Warranty 3,164,828 2,273,344 2,348,541 2,010,987 1,931,823 158,758 222,810 142,567 556,492 395,582 433,559 809,958 | 14,450,249
1| 4100 WIP eRev - (7,360) - - - - - - - - - - (7,360}
1z -
13| Total sales 6,821,106 7,362,384 13,578,089 10,577,431 9,999,682 1,184,675 1487,738 1,409,879 4,568,828 3,306,818 2,851,440 6,344,908 | 69,492,580
g

15

= 2019 - Sales 2019 - Trend

17 = Sales . 16

18 5

5| « Sales- Merchandise =

20 | = Sales - Service o

all [ T :

22 Sales- Clearance 6

2| ( = Sales- Warranty :

2

=) = WIF eRev Jan  Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec
26| 2019 2013 2019 2019 2018 2019 2015 2018 2019 2019 2019 2019
27|

28

Step 8:

From the Solution 7 ribbon, click Save Sheet(s).

Step o:

With ‘Sheeta’ highlighted, select Copy Sheet Per Automation Row.
Step 10:

With ‘Summary’ highlighted, select ‘Copy Sheet Per Workbook.

In the Name Sheet box, type ‘Summary’ and click OK.

Save as File(s) X

Sheet Selection  Options

Sheets to Save
[ Shest
[ Shest1

¥ Summary

Output Action
(O Copy Sheet Per Automation Row (® Copy Sheet Per Workbook

Name Shest Summary |

/& IMPORTANT: Your workbook will be saved before running automation.

gooly | [ OK ]| Conoel
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0 Automation complete. 2 workbook(s) saved.

QK

Go to File > Open and open your new reports. You will see that a summary sheet report has been
saved in each workbook and shows the combined values of the automated P&L (Income) Statements.

A Parameter sheet can be created in a similar way. A Parameter sheet contains driver values
for the report, which can easily be changed in one place. When you have built your parameter
sheet, simply click Save Sheet(s), select Copy Per Workbook and click OK to create a parameter
sheet in each of your workbooks.
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In the previous section, we learned about the ways you can automate an existing report and create a
Summary sheet using Solution 7. In this section, we will learn about the different ways you can control
the output of your completed report(s).

Tokens allow placeholders, in the format “{1}", to be inserted in various areas of your workbook and
substituted for values provided on the automation ‘control’ sheet when automated reports are
generated.

You can use tokens where functions aren’t supported by Excel (eg Sheet Names, in document headers
& footers and in automation email templates).

In the next exercise we will use a Token to improve the sheet names generated during automation.

In previous exercises, the generated sheet names have retained their normal Excel format - suffixed
with a number to make them unique within the workbook. In this exercise, we will learn how to use
tokens to improve the names of the resulting sheets.

Continue with the P&L (Income) Statement and automation ‘control’ sheet from the previous exercise
and with Solution 7 activated, follow these steps:-

Within the automation ‘control’ sheet, click on cell D12.
You will see a small pop-up control appear, click on it to view a list of header values.

Set the value to ‘Token 1’ (you can set up to g tokens in row 12).

A B C D E F G
Automation Sheet

This sheet is used to automate workbooks and worksheets as defined in the 'Define Automation' dialogue.
Please complete each column below with the following information:

Cell1.n The combination of automation values
Workbook Name The name given to the resulting workbook(s) (not required for printing).
Email Address The recipient(s) email address(es), separated by semi colons (not required for printing or saving).

W - e W =

10 |Where a Workbook Name or Email Address is left blank, it's value will be taken from the previous row.
11

12 |Ce|l 1 Workbook Name Email Address =
13 |HH Inc. (Consolidated) [Enter Workbook Name Here] [Enter Email Address Here] \C;” 1kb A
arkpoo

14 |HH Inc. Email Addr

15 |HH Inc. : Honeycomb Mexico _

16 |HH Inc. : Honeycomb USA Token 3

17 Token 4
Token 5 W

18
19

Page 25 of 35 Copyright © 2022 Solution 7 Ltd — All Rights Reserved



Page 26 of 35 SOIUtion

Financial Reporting

In cells D13 — D16 under Token 1, enter some values which will be used for our sheet names.

E.g. below, we have entered ‘Consolidated’, *HH Inc.’, 'USA’, ‘Mexico’ for each of our subsidiaries.

D12 = 5 Token 1

A B i D E F G

Automation Sheet

This sheet is used to automate workbooks and worksheets as defined in the 'Define Automation' dialogue.
Please complete each column below with the following information:

Cell1..n The combination of automation values
Workbook Name The name given to the resulting workbook(s) (not required for printing).
Email Address The recipient(s) email address(es), separated by semi colons (not required for printing or saving).

00 = O En e WA =

g
10 |Where a Workbook Mame or Email Address is left blank, it's value will be taken from the previous row.

11

12 |Ce|l 1 Workbook Name Email Address i |T0ken 1 1Ad] |
13 |HH Inc. (Consolidated) [Enter Workbook Name Here] [Enter Email Address Herg] Consolidated-

14 |HH Inc. HH Inc

15 |HH Inc. : Honeycomb Mexico Mexico

16 [HH Inc. : Honeycomb USA USA

17

In cell B13, under Workbook Name, enter ‘Automation exercise 6’

On the Solution 7 ribbon, click Save Sheet(s).

With ‘Sheeta’ highlighted, select Copy Sheet Per Automation Row.

In the Name Sheet box, enter ‘Income Statement for {1}’ (where ‘{1}' is a placeholder for token 1) and
click OK.

When you click OK and each new sheet is generated, the token placeholder in the sheet name will be
replaced by the token values provided in column D of the automation ‘control’ sheet.
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Save as File(s) >

Sheet Selection  Options

Sheetsto Save

¥ Shestl

et

(@ Copy Sheet Per Automation Row (O Copy Sheet Per \Workbook

Name Sheet Income Statement for {1}

£ IMPORTANT: Your workbook will be saved before running automation.

ey ([ OK ] Cancel

Automation *

o Automation complete. 1 workbook(s) saved.

Step 7:

Go to File > Open to open your automated reports. You will see that the sheets in your generated
report will now have more meaningful names than in the previous exercises.

l.e. “Income Statement for Consolidated”, “Income Statement for HH Inc.” etc.

You can also apply token placeholders to the headers & footers of your report and in the
Solution 7 “Email Sheet(s)” feature. See Exercise 10: Step 4 of this document to see an
example of using tokens when emailing your automated reports.
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In this exercise, we will learn how to use automation ‘control’ sheets to group worksheets into separate
workbooks.

Continue with the P&L (Income) Statement and automation ‘control’ sheet from the previous exercise
and with Solution 7 activated, follow these steps:-

In column A, arrange your values into a logical order for them to be grouped.

In the example below, we intend to group our consolidated and parent subsidiary reports into one
workbook and group our child subsidiary reports into a separate workbook.

B15 S X v %
A B

1 Automation Sheet

2

3 |This sheet is used to automate workbooks and worksheets as
4 |Please complete each column below with the following infor
5

6 |Cell1..n The combination of automatio
7 |Workbook Name The name given to the resultin
& |Email Address The recipient(s) email address(
g

10 'Where a Workbook Name or Email Address is left blank, it's v

21
1T

112 [Cell 1 Workbook Name
13 |HH Inc. (Consolidated)

14 |HH Inc.

15 |HH Inc. : Honeycomb USA
16 |HH Inc. : Honeycomb Mexico

=1
7T

In column B, enter some names for your generated workbooks. (E.g. ‘Consolidated’ for the
consolidated and parent subsidiary reports and ‘Americas’ for the USA and Mexico subsidiaries).
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B15 i X & f | Americas

A A | B

1 Automation Sheet

2]

3 |This sheet is used to automate workbooks and worksheets as defi
4 |Please complete each column below with the following informatil
5 |

6 |Cell1..n The combination of automation val
7 |Workbook Name The name given to the resulting wol
8 |Email Address The recipient(s) email address(es),
9 |

10 |Where a Workbook Name or Email Address is left blank, it's value
1| 3 "

12 [Cell1 Workbook Name Ema
13 |HH Inc. {Consolidated) | Consolidated I_Entl
14 [HH Inc. | i
15 |HH Inc. : Honeycomb USA | Americas i
16 |HH Inc. : Honeycomb Mexicol

Step 3:

On the Solution 7 ribbon, click Save Sheet(s).

Step 4:

With ‘Sheeta’ highlighted, select Copy Sheet Per Automation Row.

Click OK to run Automation and create your reports.

Save as File(s) >

Sheet Selection  Options

Sheets to Save

e

(®) Copy Sheet Per Automation Flow (O) Copy Sheet Per \Workbook

Mame Sheet Income Statement for {1}

b IMPORTAMNT: Your workbook will be saved before running automation.

ey ([ OK ] Caneel

Step 5:

Go to File > Open and open both of your newly generated workbooks ‘Americas.xlsx’ and
‘Consolidated.xIsx'.
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Date modified Type Size

02/03/2020 10:17

02/03/2020 10:17

M KB
40 KB

Microsoft Excel W...

Microsoft Excel W...

Both workbooks contain two reports on separate worksheets - the USA and Mexico subsidiary reports
in the ‘Americas’ workbook and the consolidated subsidiary reports in the ‘Consolidated’ workbook.

In the previous exercises, we learned how to save our automated reports to the current folder by
entering a simple name in column B. In this exercise, we will use the same automation ‘control’ sheet
from Exercise 7 and learn how to save our report directly to an alternative folder using a file path.

Continue with the P&L (Income) Statement and automation ‘control’ sheet from the previous exercise
and with Solution 7 activated, follow these steps:-

Click on cell Ba3.

Go to the formula bar and enter a file path preceding the workbook name.

Bl

0L~ R W N =

= = | =
(g

I C:\Users\employee\Documents\Solution 7\Automation exercises\Consolidated.xlsx

A

Automation Sheet

This sheet is used to automate workbooks and worksheets as defined in the 'Define Automation' dialogue.
Please complete each column below with the following information:

Cell1.n
Workbook Name
Email Address

Where a Workbook Name or Email Address is left blank, it's value will be taken from the previous row.

Cell1
HH Inc. (Consolidated)
HH Inc.

HH Inc. : Honeycomb USA
HH Inc. : Honeycomb Mexico

B

The combination of automation values
The name given to the resulting workbook(s) (not required for printing).
The recipient(s) email address(es), separated by semi colons (not required for printing or saving).

| Workbook Name
C:\Users\employee\Documents\Solution 7\Automation exercises\Consolidated.xlsx

Americas

End the file path with .xIsx’. This will save your worksheets as Excel files in the folder specified.

Repeat steps 1-2 for your other workbook names. (l.e.'Americas’).
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B15 - F C:\Users\employee\Documents\Solution 7\Americas.xlsx

A B

Automation Sheet

1

2

3 |This sheet is used to automate workbooks and worksheets as defined in the 'Define Automation' dialogue.
4 |Please complete each column below with the following information:

&

6 |Cell 1..n The combination of automation values

7 |Workbook Name The name given to the resulting workbook(s) (not required for printing).

8 |Email Address The recipient(s) email address(es), separated by semi colons (not required for printing or saving).
g

10 |Where a Workbook Mame or Email Address is left blank, it's value will be taken from the previous row.

11

12 |Cell1 Workbook Name

13 |HH Inc. {Consolidated) C:\Users\employee\Documents\Solution 7\Consolidated.xlsx

14 |HH Inc.

15 |HH Inc. : Honeycomb USA C:\Users\employee'Documents\Solution 7\Americas.xlsx

16 |HH Inc. : Honeycomb Mexicd

17

—
oo

From the Solution 7 ribbon, click Save Sheet(s).

With ‘Sheeta’ highlighted, select Copy Sheet Per Automation Row.

Click OK to run Automation. Your reports will be saved to the file paths specified in column B.

Go to File > Open and open your automated reports.

As well as saving your automated reports as Excel workbooks, you can use Automation to quickly and
easily generate your reports as PDFs (Portable Document Format). This allows the document to be
viewed as a PDF file and prevent the reports from being edited.

Continue with the automation sheet from the previous exercise and with Solution 7 activated, follow
these steps:-

In column B, specify a ‘.pdf’ extension for your workbook name. See the example below:
‘C:\Users\employee\Documents\Solution 7\Automation exercises\Consolidated.pdf’
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A B
1 Automation Sheet
2
3 |This sheet is used to automate workbooks and worksheets as defined in the 'Define Automation' dialogue.
4 |Please complete each column below with the following information:
3
6 Celll.n The combination of automation values
7 \Workbook Name The name given to the resulting workbook(s) (not required for printing).
& |Email Address The recipient(s) email address|es), separated by semi colons {not required for printing or saving).
9
10 |Where a Workbook Mame or Email Address is left blank, it's value will be taken from the previous row.
11
12 |Cell1 | Workbook Name |
13 |HH Inc. (Consolidated) C:\Users\employee\Documents\Solution 7\Automation exercises\Consolidated.pdf
14 |HH Inc.
15 |HH Inc. : Honeycomb USA C:\Users\employee\Documents\Solution 7\Automation exercises\Americas.pdf
16 |HH Inc. : Honeycomb Mexick
17
18
Step 2:

From the Solution 7 ribbon, click Save Sheet(s).
Step 3:
With ‘Sheeta’ highlighted, select Copy Sheet Per Automation Row.

Click OK to run Automation and generate your reports as PDF documents.

Step 4:

Go to File > Open to open your new PDF report templates.
&3 Americas 21/01/2020 14:40 PDF File 187 KB
[ Consolidated 21/01/2020 14:40 PDF File 187 KB

You may need to provide additional formatting and page layout options in your Excel
document for your reports to format correctly in a PDF. These options are beyond the scope of
this document.
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Exercise 10 — Emailing reports

In this exercise, we will learn how to use Automation to email reports to recipients.

Continue with the P&L (Income) Statement and automation ‘control’ sheet built in the previous
exercise and with Solution 7 activated, follow these steps:-

Step 1:

In cell Ca3, under Email Address, enter your email address. In the below example, all the workbooks
will be sent to one recipient (you).

b3 Budget.Holder@solution7.co.uk

| B C D
1 Automation Sheet
2]
3 |This sheet is used to automate workbooks and worksheets as defined in the 'Define Automation' dialogue.
4 |Please complete each column below with the following information:
5 |
6 |Cell1l.n The combination of automation values
7 |Workbook Name The name given to the resulting workboaok(s) {not required for printing).
8 |Email Address The recipient(s) email address(es), separated by semi colons {not required for printing or saving).
9 |
10| ‘Where a Workbook Name or Email Address is left blank, it's value will be taken from the previous row.
1]
12 |[Cell1 Workbook Name Email Address Token1
13 |HH Inc. {Consolidated) c:\Users\evie.rourke\Documents\Solution 7\Automation exercises\Consolidatefl Budget.Holder@solution7.co.uk (onsolidated
14 |HH Inc. HH Inc.
15 HH Inc. : Honeycomb USA C:\Users\evie.rourke\Documents\Solution 7\Automation exercises\Americas UsA
16 |HH Inc. : Honeycomb Mexico Mexico
5
18

Step 2:

On the Solution 7 ribbon, click Email Sheet(s).

Step 3:

Make sure the settings are retained from the previous exercise.

Select the Email tab.

Send to Email Recipient(s) e
Sheet Selection Opﬁo
Sheets to Email

Qutput Action
(® Copy Sheet Per Automation Fow (O) Copy Shest Per \Warkbook

Name Sheet Sheet1

£ IMPORTANT: Your workbook will be saved before running automation.

soy | O] Corce
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Step 4:
Make sure the From Address is set as your own email address.

In the Subject box, enter ‘P&L (Income) Statement Solution 7.

Enter an email message.

Send to Email Recipient(s) X

Sheet Selection Options ~ Email

Email Template
From Address |empl0yee@soluti0n 7.co.uk |
Subject |P&L {Income) Statement Solution 7 |
Hi {1}
Attached is the Solution 7 PAL report for {2}
if you have any questions, please let me know.
Regards,
Message G

£ IMPORTANT: Your workbook will be saved before running autemation.

sorly Carce

Step 5:

Click OK to run automation and send your generated reports to the email address(es) specified in the
automation ‘control’ sheet.

Email addresses can be grouped in the automation ‘control’ sheet in a similar way to how we
grouped the worksheets in Exercise 7: Grouping Worksheets.

Enter one email address to send all reports to a single recipient, enter one email address per
automation row to send each report to a single recipient, or enter multiple email addresses
separated by semi-colons to send to each report to multiple recipients.

Unable to send email(s) error

If you see this error message, you need to configure your email settings to your Solution 7 instance. To
do this, please see the Configuration Guide or contact support@solutionz.co.uk.

6_ Unable to send email(s).
| 1
4

SMTP Host has not been zet Pleasze check the email settings in the

configuration dialog.
o
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In this lesson, we have learned how to produce and use Solution 7's Automation features to easily
generate and distribute multiple reports from a single template. To understand the basic concepts of
Automation, we initially learned how to automate a single cell then multiple cells in a blank workbook.
We then applied that knowledge to automate an existing report template and generate multiple
reports across your various NetSuite segments.

When running Automation, we have seen how using the formula options we can retain, lock or remove
formulas in a report and give additional control over what the end user will receive. Furthermore, we
have seen how we can incorporate a summary sheet into our generated workbooks to help drive your
reports. We have investigated how we can further control our output by using tokens to improve sheet
names, group reports into separate documents and specify output folders by providing file paths.

Finally, we learned how to generate our reports as PDFs and distribute them automatically to email
recipients.

If you require any further assistance building or automating a report in Solution 7, please contact
support@solutionz.co.uk
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